升级至 PHP 7.4

PHP 7.4 今天正式发布了,下午给服务器做了升级,遇到了两个问题,记录下来以备需要时查看

问题一 No package 'sqlite3' found

No package 'sqlite3' found
Package requirements (sqlite3 > 3.7.4)

执行下方语句查询服务器是否安装sqlite3

sqlite3 -version

得到的版本是3.16.2,高于 PHP 7.4 要求的 3.7.4,后来知道问题在于缺少sqlite-devel依赖包。
执行下方语句安装sqlite-devel

sudo apt-get install sqlite3 libsqlite3-dev

问题二 No package 'oniguruma' found

No package 'oniguruma' found

类似问题一,缺少oniguruma,执行下方语句编译,来源:https://amon.org/oniguruma

git clone https://github.com/kkos/oniguruma.git oniguruma
cd oniguruma
./autogen.sh
./configure
make
make install

姜辰进行回复 取消回复

评论(5)

  1. 姜辰

    你最新一篇怎么404了?

    1. Shrek

      @姜辰 设置为私密了,好久没更新了,本没想发出去,不小心失误。

  2. 老杨

    7.3.12,想升级,不过 oneinstack 升级脚本不让跨版本升级,先不折腾了。

  3. 姜辰

    我。。。我还是7.3左右继续苟且吧。目前7.3.6,感觉还不错的那种。233

    1. Shrek

      @姜辰 恩,7.3 够用了